Primary User Emulation (PUE) Attack
in Cognitive Radio Networks

Software Recommended: NetSim Standard v12.1/v12.2 (32/64-bit), Visual Studio 2017/2019

Follow the instructions specified in the following link to clone/download the project folder from GitHub using

Visual Studio:
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-exchange-

project-repositories-from-github-

Other tools such as GitHub Desktop, SVN Client, Sourcetree, Git from the command line, or any client you
like to clone the Git repository.

Note: It is recommended not to download the project as an archive (compressed zip) to avoid incompatibility
while importing workspaces into NetSim.

Secure URL for the GitHub repository:

v12.1: https://github.com/NetSim-TETCOS/PUE_Attack v12.1.git
v12.2: https://github.com/NetSim-TETCOS/PUE_Attack v12.2.git

Note: The cloned project directory will contain the documentation specific to the NetSim version
(v12.1/v12.2).

Cognitive Radio (CR) is a promising technology that can alleviate the spectrum shortage problem by
enabling unlicensed users equipped with CRs to coexist with incumbent users in licensed spectrum
bands while causing no interference to incumbent communications. Spectrum sensing is one of the
essential mechanisms of CRs and its operational aspects are being investigated actively.

In a hostile environment, an attacker may modify the air interface of a CR to mimic a primary user signal’s
characteristic, thereby causing legitimate secondary users to erroneously identify the attacker as a
primary user. We coin the term primary user emulation (PUE) attack to refer to this attack. There is a
realistic possibility of PUE attacks since CRs are highly reconfigurable due to their software-based air
interface.

We create a PUE attack by adding two incumbents in the scenario in NetSim. One of the incumbents
represents a “real” primary user while the second represents a “Malicious” primary user.

Our next goal is to detect the PUEA by the secondary users. For example purposes we have set the
detection time as proportional to the distance of the secondary users from the malicious primary user.

The code given below is for an example implementation of PUE Attack.

Steps:

1. The downloaded project folder contains the folders Documentation and
PUE_Attack_Workspace directory as shown below:

PUE_Attack — O e

<« v » PUE_Attack v D Search PUE_Attack 2

L MName Date modified Type

3 Quick access
[ Desktop
4 Downloads

|| Documents

Documentation File folder

PUE_Attack_Workspace

File folder

&=/ Pictures
v >

2items 1 item selected =

2. Import PUE_Attack_Workspace by going to Open Simulation->Workspace Options->More
Options in NetSim Home window. Then select Import as shown below:


https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-exchange-project-repositories-from-github-
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-exchange-project-repositories-from-github-

3.
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It displays a window where users need to give the path of the workspace folder and click on
OK as shown below:

Impaort from

m Import Werkspace

Analyse the content of your folder or archive file to find projects and impaort
them. Browse the respective Workspace folder and import it as a current
working Workspace. This will import all the folders experiments.

Cancel

et

4. Browse to the PUE_Attack Workspace folder and click on select folder as shown below
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5. After this click on OK button in the Import Workspace window.




6. While importing the workspace, if the following warning message indicating Software Version

Mismatch is displayed, you can ignore it and proceed.

|u" Warning

Software Version Mismatch

You are importing a workspace from &4 build of MetSim into a 32
build of MetSim. After import, reset binaries for this workspace, and
then rebuild your code if you have made any changes to the source

codes.

CK

et

& —

7. The Imported workspace will be set as the current workspace automatically. To seethe
imported workspace, click on Open Simulation->Workspace Options->More Options as

shown below:
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Network Simulation/Emulation Platform
Version 12.1.21 (64 Bit)
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User Manual
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8. Open the Source codes in Visual Studio by going to Open Simulation-> Workspace Options

and Clicking on Open code button as shown below:




m MetSim Home - X

NetSim Standard

Network Simulation/Emulation Platform
Version 12.1.21 (64 Bit)

www.tetcos.com

Current workspace: PUE_Attack_Workspace

Mew Simulation Ctrl+N Experiment name Date modified Network type
PUE_Attack_Example 09-03-2020 Cognitive_Radio_Networks View Results  Export E[
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Exit
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9. Goto CognitiveRadio project=0pen SpectrumManager.c. Insidethe SpectrumManager.c
file, the code to be modified is commented as PUE Attack code. Do the required modifications.

Solution Explorer AR Bl SpectrumManager.c R X
> O 6 ‘ -5 kn ngrf iveRadio (Global Scope)
Search Solution Explorer (Ctr O ~ 290
= == = 291
fa] Solution 'NetSim’ (L project) 202 Estruct stru_882_22_SSFOutput* fn_NetSim_CR_CPE_SSF(struct stru_8@2_22_SSFInput* input,NETSIN_
4 [%] CognitiveRadio 293 {
b =B References 294 struct stru_8e2_22_SSFOutput* output = (struct stru_802_22_SSFOutput*)fnpAllocateMemory(1
P 15 External Dependencies 295 unsigned int nLoop;
b ++ 802 22.c 296 double dDistance;
b 802 22.h 297 int Additional_delay;
b 4+ DCD.c 298 %nt Detection_time;
e ie: 1::;«1:5; f; CR=NULL; // Code for PUE Attack
@ static L iy H ode for ac|
b ++ DSMAP.c — o g
P+ DSxc 302 double p = fn_NetSim_Utilities_GenerateRandomNo(8DEVICE(nDevId)->ulSeed[0],
b DSxh 303 &DEVICE (nDevId)->ulSeed[1])/NETSIM_RAND_MAX;
P *+ FCH.c 304 if(p<(double)input->nMaxProbabilityOfFalseAlram/10@.8)
P ++ Fragmentation.c 305 nflag = 1;
P #+ Incumbent.c 36
b ++ OFDMA.c 307 // Coge for PUE Attack
b ++ PacketForward.c ;g; LR CR),
. if(!Fp
P ++ PropagationModel.c T
P29 310 fp_CR=fopen("CR_Detect.txt","w");
b 4 SCH.c S22
b ©n SpectrumManager. 312 // End
b SpectrumManager.h 313
P ++ UCD.c 314 = for{nLoop=8;nLoop<input->nIncumbentCount;nLoop++)
P ++ USFrame.c 315 {
b ++ USMAP.c 316 =] if(input->pstrulncumbent[nLoop]->nIncumbentStatus == IncumbentStatus_OPERATIOAL)
317 {
318 dDistance = fn_NetSim_Utilities_CalculateDistance(DEVICE_POSITION(nDevId),input->
Solution Explorer # X
COoR| o-5F ~|  (Global Scope)
Search Solution Explorer (Ctr  + 302 double p = fn_NetSim_Utilities_GenerateRandomNo(8DEVICE(nDevId)->ulSeed[@],
VT . 303 &DEVICE (nDevId)->ulSeed[1])/NETSIM_RAND_MAX;
] Solution 'NetSim' 1 project) 304 17 (p<(double) input->nilaxProbabilityOfFalseAlran/100.0)
4 [%] CognitiveRadio 305 nflag = 1;
b = References 306
b 1 External Dependencies 307 // Code for PUE Attack
b+ 802.22.c
b 802_22.h if(1Fp_CR)
b +s DCD.c fp_CR=fopen("CR_Detect.txi
b ++ DSFrame.c -
b ++ DSMAP.c "
P A DStc & for(nLoop=2;nLoop<input->nIncumbentCount ;nLoop++)
b [ DSxch i
b *+ FCH.c F if(input->pstrulncumbent[nLoop]->nIncumbentStatus == IncumbentStatus_OPERATIOAL)
P ++ Fragmentation.c {
b 4 Incumbent.c dDistance = fn_NetSim_Utilities_CalculateDistance(DEVICE_POSITION(nDevId),input->pstrulncumbent{nLoop]->position);
b ++ OFDMAc ) if(dDistance <= input->pstrulncumbent[nLoop]->dKeepOutDistance)
b ++ PacketForward.c i € R g
b ++ PropagationModel.c e JECUmENE deLecen
DeER e 323 // #sssxsssxx PUE Attack project code start
b <o SpectrumManager. 320 | // dDistance is the distance between CR CPE and incumbent and is got from above
b [} SpectrumManager.h 325 | Additional_delay = dDistance / 18;
b ++ UCD.c 326 & // We have randomly set 1@ as the velocity of the signal based on which
b+ USFrame.c 327 // the additional delay is got. I you increase this you will see a lower
b ++ USMAP.c 328 // delay and vice versa
329
330 Detection_time = pstruEventDetails->dEventTime + Additional_delay;
331 fprintf(fp_CR,"Time to detect incumbent %d by CPE¥d is %d microseconds \n",nLoop+1,nDevId,Detection_time};
332 fflush(fp_CR);
333
334 /1 *=sexs==xx Project code end
335
336 //check for possible interference




10. Based on whether you are using NetSim 32 bit or 64 bit setup you can configure Visual studio
to build 32 bit or 64 bit DIl files respectively as shown below:
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11. Right click on the Solution in the solution explorer and select Rebuild.
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12. Upon successful build modified libCognitiveRadio.dll file gets automatically updated in the
directory containing NetSim binaries.

13. Then PUE_Attack_Workspace comes with a sample configuration that is already saved. To
open this example, go to Open Simulation and click on the PUE_Attack_Example that is
present under the list of experiments as shown below:
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14. The network scenario loads as shown below:
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Following settings were done in the devices for this example.
15. In CR-Base_Station_1/INTERFACE_1 (COGNITIVE_RADIO) Incumbent properties, the
Incumbent count is set as 2
16. In the Incumbent properties:

In malicious (Incumbent_1), ON_Duration(s) — 4, OFF_Duration(s) —10
In Incumbent (Incumbent_2), ON_Duration(s) — 9, OFF_Duration(s) —9
Keep Distance = 500m in both incumbent and the distance between the CPE and Incumbent is
<500. This ensures that the incumbent is detected. If the incumbent is beyond the keep out
distance then it is not detected.

The timing diagram is as follows:

Malicious --- Os to 10s (OFF), 10s to 14s (ON), 14s to 24s (OFF), 24s to 28s (ON) ... and so on
Incumbent --- 0s to 9 s (OFF), 9s to 18s (ON), 18s to 27s (OFF), 27s to 36s (ON) ... and so on



mi Cr_Bs
Cr Bs ¥ DATALINK_LAYER
B ON_Duration(s) | P
GEMNERAL OFF_Durationis) | 10
INTERFACE_1 (COGN Keepout_Distance(m) | 500
Oper_Distribution | Constant
INCUMBENT2
Mame Incumbent 2
D 2
X_Co_Ordinate | 50
Y¥_Co_Ordinate | 100
Z_Co_Ordinate 0
Oper_Freg_Start{MHz) | 4
Oper_Freg_End(MHz) | 60
ON_Duration(s) | Q
QOFF_Durationis) | Q
Keepout_Distance{m) | 500
» PHYSICAL_LAYER
OK Reset

17. In physical layer, the IFQP_Bitmap is set to 2000000000000000




l [N CrBs

» DATALINK_LAYER

Cr Bs
' v PHYSICAL_LAYER

HesnL FFT Size 2048

INTERFACE_1 {COGNITIVE_RADIO) CP_Factor 1116 -
Self Coexistance Mo
DCD_Interval(s) 10
UCD_Interval(s) 10
BW_Req_Backeff_Start ‘ 1 |
BW_Req_Backoff End ‘ 7 |
UCC_Rspns_WatTme(s) 2
TTG{microsec) 210
DL_UL_Ratio ‘ 1:1 - |
IFQP_Cycle_Length | 1 |
IFQP_Bitmap ‘ 1000000000000000 |
IFQP Duration(Syrmbaols) 1
Connection_Medium WIRELESS
Reference Distance dl(m) ‘ 1 |

oK Reset

18. Now run the simulation 50 Sec.
19. You can see the delay in the CR_Detect.txt file inside bin folder. This additional delay has
been set by the following code,

Additional_delay = dDistance/ 10;
(You can also change the values as 10/100/1000 and analyse different variation in delay.)

A file “CR_Detect.txt” will be created in the bin folder (NetSim installation directory) with the following
contents:

| CR_Detect.txt - Notepad — O =
p

File Edit Format View Help
hime to detect incumbent
Time to detect incumbent
Time to detect incumbent
Time to detect incumbent
Time to detect incumbent
Time to detect incumbent
Time to detect incumbent
Time to detect incumbent

by CPE2 is 9129741 microseconds
by CPE3 is 9129761 microseconds
by CPE2 is 248459741 microseconds
by CPE3 is 248459761 microseconds
by CPE2 is 38129741 microseconds
by CPE3 is 38129761 microseconds
by CPE2 is 458089741 microseconds
by CPE3 is 45889761 microseconds

fFd Bd =2 =2 = 2 R R

This is a simple implementation of creating and detecting a PUE Attack by making modifications to primary
user detection in CR.



