LTE Discontinuous Reception (DRX)

Software Recommended: NetSim Standard v12.1 (32/64 bit), Visual Studio 2019

Follow the instructions specified in the following link to clone/download the project folder from GitHub
using Visual Studio:
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-

exchange-project-repositories-from-github-

Other tools such as GitHub Desktop, SVN Client, Sourcetree, Git from the command line, or any client
you like to clone the Git repository.

Note: It is recommended not to download the project as an archive (compressed zip) to avoid
incompatibility while importing workspaces into NetSim.

Secure URL for the GitHub repository:

https://github.com/NetSim-TETCOS/LTE_DRX_v12.1.git

Introduction:

Reference:
https://www.sharetechnote.com/html/Handbook LTE DRX.html
https://onlinelibrary.wiley.com/doi/abs/10.1002/ett.3579

In normal operation, UE has to be awake all the time and monitor PDCCH for every subframe meaning
that it has to be awake all the time since it doesn't know exactly when the network will transmit the data
for it. Logically there is no problem with this, but there would be a practical problem. It is power
consumption issue on UE side. If UE is always up even when there is no data being transmitted to it
from the network, it would be wasting the energy. Then what would be the solution to save the energy
on UE side. There may be several ways, but one of the most common way is to use DRX. DRX is a
mechanism in which UE gets into sleep mode for a certain period and wake up for another period of
time.
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We design DRX as a three-state model as shown above. These states are (1) active state, (2) ON state,
and (3) sleep state. The UE can receive packets during the active state. In case of no packet in the
buffer, UE waits until the expiry of inactivity timer. If UE receives an intimation of packets arrival before
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the expiry of inactivity timer, then inactivity timer gets restarted. In case if no packet arrives and inactivity
timer completes its countdown, UE switches to sleep state. After the completion of sleep time, the UE
switches to ON state to monitor the PDCCH for new packets in the buffer. If the buffer has any packet
to be served, the UE transits from ON state to active state; otherwise, the UE continues to sleep and
saves the power.
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Shown above is a timing diagram of DRX algorithm in RRC_Con mode. The DRX algorithm starts with
inactivity timer (TI). The Tl continues to countdown from the time instant when all packets in the buffer
are served to UE. The Tl restarts when a new packet arrives. If no new packet arrives before the expiry
of Tl, the UE enters into short sleep cycle(TSC). The moment when Tsc expires, the UE switches to
listening mode (T ON) to monitor PDCCH. If there is any packet indication during T ON, the UE shifts
to active mode, else UE continues to sleep. At the expiry of short sleep timer (TN SC),UE switches to
long sleep state (TLC). The UE will remain in this state until TLC gets expired. Similar to the short sleep
state, listening state (T ON) is activated after the expiry of long sleep cycle to monitor the PDCCH. In
case of any new packet indication, TLC is terminated and UE transits to the active state. This process
is repeated in RRC_Con mode. Table 1 shows the list of parameters in RRC_Con, which can be
controlled and configured through RRC. The optimum configurations of DRX parameters in RRC_Con
mode might improve the Quality of Service (Qo0S).

The source codes of LTE project, which is part of NetSim protocol source codes, is modified for this
implementation. The LTE DRX project workspace which contains the modified code and related network
scenarios which were considered for the implementation can be accessed as explained below.

Follow the instructions specified in the following link to clone/download the project folder from GitHub
using Visual Studio:
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-
exchange-project-repositories-from-github-

Other tools such as GitHub Desktop, SVN Client, Sourcetree, Git from the command line, or any client
you like to clone the Git repository.

After cloning the workspace locally, you can import the WorkSpace LTE_DRX into NetSim by going to
Open Simulation -> Workspace Options -> More Options and clicking on the Import button.

While importing the workspace, if the following warning message indicating Software Version Mismatch
is displayed, you can ignore it and proceed.
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The imported workspace consists of two examples which can be opened from the Open Simulation
option as shown below:

[T¥ NetSim Home — X
NetSim Standard
MNetwork Simulation/Emulation Platform
Version 12.1.21 (64 Bit)
Current workspace: WorkSpace LTE_DRx v12 1 O\ |
Mew Simulation Cirl+N Experiment name Date modified Network type
LTE_DRX_EXAMPLE_2 30-04-2020 LTE TiT
| Open Simulation Ctd+0
LTE_DRX_EXAMPLE_1 30-04-2020 LTE TiT
Examples
License Settings
Exit
Workspace options.. mport Experiment
Support Learn Documentation Contact us
/FAQ s Email - sales@tetcos.com
t Technical Support iments Manua Phone - +91 767 605 4321
Email - support@tetcos.com

The source codes modified for this project can be accessed by going to Open Simulation -> Workspace
Options and clicking on the Open Code button as shown below:
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The files LTE.c, LTE.h, LTE_enum.h, Mac_scheduler.c and RRC.c which are part of the LTE project
were modified for this implementation.

The line #define DRX_ENABLE 1 in the LTE.h file can be commented to run simulations without DRX
and get the energy consumption of devices in the results dashboard.

The same line can be uncommented to run simulations with DRX mode enabled for the UE's and get
the energy consumption of the devices in the results dashboard.
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The DRX states are defined in the LTE.h file as shown below:
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DRX timer and radio state related variables are added
shown below:
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The various timer nts related to DRX states and timers are declared in the LTE_enum.h file as
shown below:
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The timer events related to DRX are defined in the funciton fn_NetSim_LTE_Run() under
TIMER_EVENTS as shown below:
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Some more sections of the LTE.c and RRC.c source codes were modified to add battery model for the
UE's and to change radio states of the UE's periodically.

The source codes of the MAC_Scheduler.c file were modified to check whether the UE is in sleep state
before adding packets to the downlink queue.

Simulation Results and Analysis:

In Visual Studio, set to platform to win32 or x64 based on the build of NetSim(32-bit or 64-bit) that you
have installed.

Right click on the LTE project and select rebuild to build the source codes.

The LTE_DRX_EXAMPLE_1 consists of two UE's connected to a ENB out of which one UE performs
download as shown below:
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Upon running the simulations with and without DRX enable, we get the following energy consumption
metrics:

With DRX disabled:

e
Battery model Detailed View
Device Mame  Initial energy(mJ) Consumed energy(mJ) Remaining Energy(mJ) Active energy(mJ) Sleep energy(ml)
UE_2 129600.000000 122.387760 120477.612240 122.387760 0.000000
UES 129600.000000 122.387760 128477.612240 122.387760 0.000000

With DRX enabled:

Battery model Detailed View
Device Name  Initial energy(mJ) Consumed energy(mJ) Remaining Energy(mJ) Active energy(ml) Sleep energy(ml)
UE_2 129600.000000 61.108582 129538.891418 18.298837 42809745

UES 129600.000000 50.416603 129548,583397 0122473 50.294130

When DRX is enabled, nodes switch to sleep state due to which Sleep energy consumption can be
found in the above table. Energy consumed by the devices are also lesser in case of DRX enabled
since energy consumed in sleep mode is lesser than that of active mode.

The events related to DRX can be found in the Even Trace log file as shown below:
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The LTE_DRX_EXAMPLE_2 consists of five UE's connected to a ENB out of which three UE’s performs
download as shown below:

500 1000 2500 3000

Wi

Y
\pp1_CER

o

UE_2

Upon running the simulations with and without DRX enable, we get the following energy consumption
metrics

With DRX disabled:
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Battery model [/ Detailed View
Device Name Initial energy(mJ) Consumed energy(mJ) Remaining Energy(mJ) Active energy(mJ) Sleep energy(mJ)

UE_2 129600.000000 122.387760 129477.612240 122.387760 0.000000
UE_3 129600.000000 122.387760 129477.612240 122.387760 0.000000
UE_4 129600.000000 122.387760 129477.612240 122.387760 0.000000
UE_S 129600.000000 122.387760 129477.612240 122.387760 0.000000
UE_6 129600.000000 122.387760 128477.612240 122.387760 0.000000

With DRX enabled:

Battery model Detailed View
Device Name Initial energy(mJ) Consumed energy(mJ)) Remaining Energy(mJ) Active energy(m)) Sleep energy(mJ)

UE_ 2 129600.000000 61.108582 120538.801418 18.208837 42809745
UE_3 129600.000000 50416668 120549.583332 0.122584 50.204084
UE 4 129600.000000 61.108603 120538.801397 18.208873 42809730
UE_3 129600.000000 50416646 129549.583354 0122547 50.294100
UE 6 129600.000000 61.108625 120538.891375 18.298910 42809715

When DRX is enabled, nodes switch to sleep state due to which Sleep energy consumption can be
found in the above table. Energy consumed by the devices are also lesser in case of DRX enabled
since energy consumed in sleep mode is lesser than that of active mode.

The events related to DRX can be found in the Even Trace log file as shown below:
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13 TIMER_EVENT 10000 ENB 1 [) 3 [) oLTE DRX_CHECK_BUFFER_STATUS o )

143 TIMER_EVENT 20000 ENB 1 o 3 o 0 LTE DRX_CHECK_BUFFER_STATUS 0 13

144 TIMER_EVENT 20003 UE 2 0 3 0 oLTE [DRX_INACTIVITY_TIMER_EXPIRE | ° 13

145 TIMER_EVENT 20006 UE 4 o 3 o 0 LTE DRX_INACTIVITY_TIMER_EXPIRE 0 13

145 TIMER_EVENT 20009 UE 6 0 3 0 oLTE [DRX_INACTIVITY_TIMER_EXPIRE | ° 13

147 TIMER_EVENT 20012 UE 5 o 3 o 0 LTE DRX_INACTIVITY_TIMER_EXPIRE 0 13

148 TIMER_EVENT 20015 UE 3 0 3 0 oLTE [DRX_INACTIVITY_TIMER_EXPIRE | ° 13

166 TIMER_EVENT 23003 UE 2 o 3 o 0 LTE DRX_SHORT_SLEEP 0 144

167 TIMER_EVENT 23006 UE 4 0 3 0 oLTE DRX_SHORT Steep | ° 185

168 TIMER_EVENT 23009 UE 6 o 3 o 0 LTE DRX_SHORT_SLEEP 0 146

169 TIMER_EVENT 23012 UE s 0 3 0 oLTE DRX_SHORT Steep | ° 147

170 TIMER_EVENT 23015 UE 3 o 3 o 0 LTE DRX_SHORT_SLEEP 0 148

174 TIMER_EVENT 25003 UE 2 0 3 0 oLTE DRX_TIMERON | ° 166

175 TIMER_EVENT 25006 UE 4 o 3 o 0 LTE DRX_TIMER_ON 0 167

176 TIMER_EVENT 25009 UE 6 0 3 0 oLTE DRX_TIMERON | ° 168

177 TIMER_EVENT 25012 UE s 0 3 0 oLte DRX_TIMER_ON 0 169

178 TIMER_EVENT 25015 UE 3 0 3 0 oLTE DRX_TIMERON | ° 170

181 TIMER_EVENT 28003 UE 2 0 3 0 oLte DRX_SHORT_SLEEP 0 17

182 TIMER_EVENT 28006 UE 4 0 3 0 oLTE DRX_SHORT Steep | ° 175

183 TIMER_EVENT 28009 UE 5 0 3 0 oLte DRX_SHORT_SLEEP 0 175

184 TIMER_EVENT 28012 UE s [} 3 [} oLTE DRX_SHORT StEep | ° 177

185 TIMER_EVENT 28015 UE 3 0 3 0 oLte DRX_SHORT_SLEEP 0 178

159 TIMER_EVENT 30000 ENB 1 [} 3 [} oLTE DRX_CHECK_BUFFER_STATUS | ° 143

160 TIMER_EVENT 30003 UE 2 0 3 0 oLte DRX_INACTIVITY_TIMER_EXPIRE 0 143

189 TIMER_EVENT 30003 UE 2 [} 3 [} oLTE DRX_TIMERON | ° 181

161 TIMER_EVENT 30006 UE 4 0 3 0 oLTe DRX_INACTIVITY_TIMER_EXPIRE o 143

150 TIMER_EVENT 30006 UE 4 [} 3 [} oLTE DRX_TIMERON | ° 182

162 TIMER_EVENT 30009 UE 5 0 3 0 oLTe DRX_INACTIVITY_TIMER_EXPIRE o 143

151 TIMER EVENT 30009 UE 5 o 3 o oLTE o 183 =
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