Wireless Energy Harvesting for the Internet of Things

Software Used: NetSim Standard v11.1 (32/64-bit), Visual Studio 2017/2019

Follow the instructions specified in the following link to clone/download the project folder from GitHub
using Visual Studio:
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-

exchange-project-repositories-from-github-

Other tools such as GitHub Desktop, SVN Client, Sourcetree, Git from the command line, or any client
you like to clone the Git repository.

Note: It is recommended not to download the project as an archive (compressed zip) to avoid
incompatibility while importing workspaces into NetSim.

Secure URL for the GitHub repository:
https://github.com/NetSim-TETCOS/Energy-Harvesting-in-loT.git
Introduction:

Among different energy harvesting methods, such as vibration, light, and thermal energy extraction,
wireless energy harvesting (WEH) has proven to be one of the most promising solutions by virtue of
its simplicity, ease of implementation, and availability. This recent technology trend in energy
harvesting provides a fundamental method to prolong battery longevity. While harvesting from the
aforementioned environmental sources is dependent on the presence of the corresponding energy
source, RF energy harvesting provides key benefits in terms of being wireless, readily available in the
form of transmitted energy (TV/radio broadcasters, mobile base stations and handheld radios), low
cost, and small form factor implementation.

A WEH-enabled sensor device usually consists of an antenna, a transceiver, a WEH unit, a power
management unit (PMU), a sensor/processor unit, and possibly an onboard battery. The available
harvested power, PH, is given by a Friis equation and is directly proportional to the transmitted power,
PT, path loss, PL, transmitter antenna gain, GT, receiver antenna gain, GR, power conversion
efficiency of the converter, PCEH, and the square of the wavelength, I, and is inversely proportional to
the square of the communication distance, r, between the source and the device.

The communication energy consists of ELS (listening energy), ERX (receiver energy), and ETX
(transmitter energy). The computation energy includes EPR (processing energy) and ESN (sensing
energy). To capture the energy distribution among the aforementioned energy consumers, weighting
coefficients aLS > aTX > aRX > aPR > aSN are assigned to them. The total
average energy consumption ED = alLS ELS + aTX ETX + aRX ERX + aPR EPR + aSN ESN. EB is
the total energy stored in the battery, and EH is the available harvested energy per active duty cycle.
We assume constant energy consumptions for receiver, processor, and sensor. However, the energy
consumption of the transmitter (ETX) is directly proportional to rj 2, where rj is the distance between
the originating device j and the sink node i (in ring topology) or the sink node/sensor device (in
multihop topology).The harvested energy EH is inversely proportional to rj 2 (here j is the sink node
and rj = rji).
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The code given below is for an example implementation of WEH whereby energy is harvested
based on the received signal power. The Steps to be followed for Implementation in NetSim

are:

1. The downloaded project folder contains the folders Documentation and
WSN_Energy Harvesting_Workspace directory as shown below:

| @ = | Energy Harvesting in loT - O *
Home Share View 0
« = v 4 <« Desktop » Energy Harvesting in loT v @ Search Energy Harvesting in loT 0@
~ MName Date modified Type
7 Quick access
Documentation 29-03-201911:45 File folder
& OneDrive WSN_Energy_Harvesting_Workspace 20-03-2019 11:45 File folder
3 This PC
_J 30 Objects
[ Desktop
E] Documents
* Downloads
J‘& Music
v >

2items 1 item selected

Import WSN_Energy_Harvesting_Workspace by going to Open Simulation->Workspace

2.
Options->More Options in NetSim Home window. Then select Import as shown below:
[T NetSim Home - x
NetSim Standard
Network Simulation/Emulation Platform
Version 11.1.11 (64 Bit)
Current workspace: NetSim_11.1.11_64_std_default
New Simulation Ctrl+N Workspace name Location Description
MNetSim_11.1.11_64 _std_default C:\Users\TETCOS-PC NetSim default Workspace Export w
| Open Simulation Cir+0
Examples
License Settings
New. I Import I Back
Support Learn Documentation Contact us
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ical Support Phone - +91 767 605 4321
rt@tetcos.com
3. Itdisplays a window where users need to give the path of the workspace folder and click on

OK as shown below:

|::E Import Workspace >
Analyse the content of your folder or archive file to find projects and import
them. Browse the respective Workspace folder and import it as a current
waorking Workspace. This will import all the falders experiments.

Impaort from

QK Cancel




Browse to the WSN_Energy Harvesting_ Workspace folder and click on select folder as
shown below:

Select Folder x
- v <« Ener.. » WSM_Energy_Harvesting_Wo... v | O Search WSMN_Energy_Harvesti.. 0O

Organize New folder SEEE (7]
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Folder: | WS5N_Energy_Harvesting_Workspace

Select Folder Cancel

After this click on OK button in the Import Workspace window.
While importing the workspace, if the following warning message indicating Software Version
Mismatch is displayed, you can ignore it and proceed.

|:!’ Warning >

Software Version Mismatch

You are importing a workspace from 64 build of Metsim intoa 32
build of MetSim. After import, reset binaries for this workspace, and
then rebuild your code if you have made any changes to the source
codes.

OK

The Imported workspace will be set as the current workspace automatically. To see the
imported workspace, click on Open Simulation->Workspace Options->More Options as
shown below:
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8. Open the Source codes in Visual Studio by going to Open Simulation-> Workspace Options

and Clicking on Open code button as shown below:
- X

’—!’E MetSim Home

NetSim Standard

Network Simulation/Emulation Platform
Version 11.1.11 (32 Bit)
Q ‘
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9. Expand BatteryModel Project and double click on the BatteryModel.h file to open it. The
following changes(highlighted in red) were done to the code:
_declspec(dllexport) void battery_animation();

_declspec(dllexport) void battery_metrics(PMETRICSWRITER metricsWriter);



10.

11.

12.

_declspec(dllexport) double battery_get _remaining_energy(ptrBATTERY battery);
_declspec(dllexport) int battery _energy_harvesting(ptrBATTERY battery, double
eh_energy);

_declspec(dllexport) double battery_get _consumed_energy(ptrBATTERY battery, int
mode);

Now double click on the BatteryModel.c file to open the file. The following
changes(highlighted in red) were done to the code:
_declspec(dllexport) double battery _get_remaining_energy(ptrBATTERY battery)

{
}

return battery->remainingEnergy;

_declspec(dllexport) int battery _energy harvesting(ptrBATTERY battery, double
eh_energy)
{

battery->remainingEnergy +=eh_energy_mJ;

}

Expand ZigBee project and double click on the ChangeRadioState.c file to open it. At the end
of ChangeRadioState.c file the following lines of code are added:

#define EH_FRACTION 0.1

/I EH_FRACTION is the fraction of the received signal energy that can be
/I captured and harvested by the sensor.

int calculate_eh(NETSIM_ID devi1, NETSIM_ID dev2)

{

double rx_pwr = GET_RX_POWER_mw(dev1l, dev2, pstruEventDetails-
>dEventTime);

double eh_energy= EH_FRACTION * rx_pwr;

ptrBATTERY battery = WSN_PHY(dev?2)->battery;

if(battery)

battery_energy_harvesting(battery, eh_energy);

}

The function call shown in red is added to 802_15_4.c file

case UPDATE_MEDIUM:
{
double dtime=pstruEventDetails->dEventTime;
NETSIM_ID nLink_Id, nConnectionID, nConnectionPortID, nLoop;
NETSIM_ID nTransmitterlD;
nTransmitterIlD = pstruEventDetails->nDeviceld;
ZIGBEE_CHANGERADIOSTATE(nTransmitterID, WSN_PHY(nTransmitterID)-
>nRadioState, RX_ON_IDLE);
if( WSN_PHY(nTransmitterID)->nRadioState !|= RX_OFF)
WSN_MAC(nTransmitterID)->nNodeStatus = IDLE;
nLink_ld = fn_NetSim_Stack_GetConnectedDevice(pstruEventDetails-
>nDeviceld,pstruEventDetails->ninterfaceld,&nConnectionID,&nConnectionPortID);
for(nLoop=1; nLoop<=NETWORK->ppstruNetSimLinks[nLink_ld-1]-
>puniDevList.pstruMP2MP.nConnectedDeviceCount; nLoop++)

{
NETSIM_ID ncon = NETWORK->ppstruNetSimLinks[nLink_Id-1]-
>puniDevList.pstruMP2MP.anDevids[nLoop-1];
if(ncon != pstruEventDetails->nDeviceld)

{

calculate_eh(nTransmitterID, nLoop);



WSN_PHY(ncon)->dTotalReceivedPower -=
GET_RX_POWER_mw(nTransmitterlD,ncon,pstruEventDetails->dEventTime);
if( WSN_PHY(ncon)->dTotalReceivedPower < WSN_PHY(nhcon)-
>dReceiverSensivity)
WSN_PHY(ncon)->dTotalReceivedPower = 0;

}

This completes the code modifications for for energy harvesting.

13. Based on whether you are using NetSim 32 bit or 64 bit setup you can configure Visual studio

to build 32 bit or 64 bit DI files respectively as shown below:
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14. Right click on the Solution in the solution explorer and select Rebuild.
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15. Upon successful build modified libZigBee.dll and BatteryModel.dll file gets automatically

updated in the directory containing NetSim binaries.



16. Then WSN_Energy Harvesting Workspace comes with a sample configuration that is
already saved. To open this example, go to Open Simulation and click on the
WSN_Energy_Harvesting_Example that is present under the list of experiments as shown

below:
[1% NetSim Home — X
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AQ User Manual Email - sales@tetcos.com
chnical Support Manua! Phone - +91 767 605 4321
Email - support@tetcos.com

COMPARATIVE ANALYSIS:

1. Create a network scenario in 10T with say 16 sensors, a 6LoWPAN Gateway, a Router and a
Wired Node as shown below:
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2. Configure traffic in the network by setting a few applications between some of the sensor

nodes to the Wired Node using the Application Icon, as shown below:
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3. Disable Energy Harvesting in the Sensor nodes by setting the EnergyHarvesting parameter to
OFF in the Interface(ZigBee) Properties of the sensor nodes as shown below:

m lot_Sensors ] X
lot_Sensors » NETWORK_LAYER
» DATALINK_LAYER
G ¥ PHYSICAL LAYER
Antenna Gain | 0 | i
APPLICATION_LAYER
Antenna Height{m) | 1 |
TRANSPORT_LAYER
Connection_Medium WIRELESS
NETWORK_LAYER
Reference Distance di{m) | 8 |
INTERFACE_1 (ZIGBEE)
POWER
PowerSource | Battery - |
EnergyHarvesting Cn -
RechargingCurrent{mA)
InitialEnergy(mAH)
TransmittingCurrent(ma) | 8.8 |
IdieModeCurrent{mA) | 33 |
Voltage(V) | 36 |
ReceivingCurrent(mA) | 9.6 |
SleepModeCurrent{mA) | 0.237 |
0K Reset

4. Run Simulation for say 100 seconds and save the simulation results. In NetSim Simulation
Results Window, the Battery model table provides detailed metrics related to energy
consumed by each sensor node. The column Remaining energy can be used to compare
simulations with and without energy harvesting code modification.

WITH ENERGY HARVESTNG

1. Now re-run the network simulation for 100 seconds and save the simulation results. You can
use the table remaining energy column present in the Battery model table which is part of
NetSim Simulation Results window to compare simulations with and without wireless energy
harvesting.



Batter model Detailed View

Device Name Initial energy(mJ) Consumed energy(mJ) | Remaining Energy(mJ) } Transmitting energy{mJ) Receiving energy(m)) Idle energy(mJ)) Sleep energy(m))
WIRELESS_SENSOR_1 6480.000000 1208.785999 6273.714001 18.100463 32081633 1158.603902 0.000000
WIRELESS_SENSOR_2 6480.000000 1182.780044 6373.719956 4.010593 5.872435 1172.897015 0.000000
WIRELESS_SENSOR_3  6480.000000 1179.353731 6377.146269 4010593 0.651387 1174691751 0.000000
WIRELESS_SENSOR 4 6480.000000 1178.926258 6377573742 4010593 0.000000 1174.915665 0.000000
WIRELESS_SENSOR_5 6480.000000 1178.926258 6377.573742 4,010593 0.000000 1174.915665 0.000000
WIRELESS_SENSOR_6 6480.000000 1178.879332 6378620668 3.935511 0.000000 1174.943821 0.000000
WIRELESS_SENSOR_7 6480.000000 1178.926258 6377.573742 4.010593 0.000000 1174.915665 0.000000
WIRELESS_SENSOR_8  6480.000000 1178.926258 6377.573742 4010593 0.000000 1174.915665 0.000000
WIRELESS_SENSOR 9 6480.000000 1178.902795 6378.0097205 3.973052 0.000000 1174929743 0.000000
WIRELESS_SENSCR_10  6480.000000 1178.926258 6377.573742 4,010593 10.000000 1174.915665 10.000000
WIRELESS_SENSCR_11  6480.000000 1178.902795 6378.097205 3.973052 0.000000 1174.929743 0.000000
WIRELESS_SENSOR_12  6480.000000 1178.926258 6377.573742 4.010593 0.000000 1174.915665 0.000000
WIRELESS_SENSOR_13  6480.000000 1188.994004 6288.005996 19.258525 0.819487 1168.915992 0.000000
WIRELESS_SENSCR_14  £480.000000 1178.926258 6377573742 4010593 0.000000 1174.915665 0.000000
WIRELESS_SENSCR_15  6480.000000 1178.926258 6377.573742 4.010593 0.000000 1174.915665 0.000000

Now on comparing the custom IOT metrics we can observe that Energy Harvesting increases
sensors’ working capability. Simulations can be performed for different values of EH Fraction which
may vary as per the efficiency of the Energy Harvesting unit.



