
Simulation of WSN in NetSim Clustering using Self-Organizing Map 

Neural Network 

 

 

Software Recommended: NetSim Standard v11.1 (32/64bit), Visual Studio 2015/2017, MATLAB (32/64 

bit) 

Follow the instructions specified in the following link to clone/download the project folder from GitHub using 

Visual Studio: 

https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-

exchange-project-repositories-from-github- 

 
Other tools such as GitHub Desktop, SVN Client, Sourcetree, Git from the command line, or any client you 

like to clone the Git repository. 

 

Note: It is recommended not to download the project as an archive (compressed zip) to avoid incompatibility 

while importing workspaces into NetSim. 

 

Secure URL for the GitHub repository:  

https://github.com/NetSim-TETCOS/SOM_Optimization_Project_v11.1.git 

Objective 

The goal of this project is to maximize the life time of a Wireless Sensor network using Self Organizing Map 

(SOM) based Neural Network algorithms for cluster head selection.  

Introduction 

We define the lifetime of a WSN as the time at which the power of half the sensors reach zero (also called 

half-life of Network).  Initially all sensors start with a fixed amount of energy. Subsequently energy is 

consumed during transmission, reception and idle states. Packets are transmitted from sensors to their 

cluster head sensor and then it is forwarded to sink node through other cluster heads. The selection of the 

cluster heads is done using SOM.  

All MAC / PHY layer simulations are carried using NetSim while the cluster head selection using SOM 

algorithm is done using MATLAB.  

Self-Organizing Map based Neural Network 

We would be using a 2 Dimensional SOM to get a k sized cluster from n sensors located in 2D space using 

distance as a metric for clustering. 

https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-exchange-project-repositories-from-github-
https://tetcos.freshdesk.com/support/solutions/articles/14000099351-how-to-clone-netsim-file-exchange-project-repositories-from-github-


 

Fig 1: A neural network of k 2D lattice points where red points represent the lattice points (nodes) and the 

green points (neuron) represent the input layer. The connections between the red and green points 

represent the links 

As shown in the above figure, a neural network is created from k 2D lattice points (also known as nodes) 

each of which is connected with the input layer. Each link has an associated weight. As the input vectors 

are 2D points here, there are 2 neurons in input layer of neural network. Each node has a topological 

position (x coordinate and y coordinate) and also a weight vector of 2 dimensions (one weight for each 

dimension).  

So, with input vectors and weight vectors, the SOM algorithm explained below, orders the weight vectors 

in a way that represents similarities with input vectors. 

There are following steps of the algorithm: 

1. Each node weights are randomly initialized. 

2. Choose an input vector and find that node whose weight vector is closest to the chosen point. 

The most common method to calculate distance is finding the Euclidean distance. This node is 

called BMU (Best matching unit). 

3. The neighborhood of BMU is defined as all the nodes lying within its radius of influence. The no of 

neighbors decreases over time because Radius of influence is decreased over time. 

4. The weight vector associated with neighbor node (and BMU too) is updated using following 

equation – 

iw(q)=iw(q−1)+α(p(q)−iw(q−1)) 

Where p(q) is the input vector chosen and  iw(q-1) is the weight vector associated with node i  and 

iw(q) is the updated  value of weight vector. 

5. Repeat from step 2 till the iteration limit has been reached. 

The above procedure is repeated for large no of iterations (chosen as 200 in our example) 

There would be k output nodes in the neural network where each output node is associated with some 

pattern or cluster in the input point.  



Each point would be passed through network and suppose ith output node has highest value, then this 

point belongs to the cluster i. 

The topology function of the k nodes and the distance function used to evaluate distance between sensor 

and node can be chosen from a given set of values as below. 

Topology 

The neurons in the layer of an SOFM are arranged originally in physical positions according to a topology 

function. The function gridtop, hextop, or randtop can arrange the neurons in a grid, hexagonal, or random 

topology. 

1. The gridtop topology starts with neurons in a rectangular grid of dimensions which you may specify. 

Suppose you want to classify n points into k clusters. Then, you can start with k neurons arranged in 

rectangular grid of dimensions [k1 k2] such that k1*k2=k. 

e.g.- 

pos = gridtop([2, 3]) 

pos = 

     0     1     0     1     0     1 

     0     0     1     1     2     2 

Suppose you had chosen dimensions to be [3, 2], then you would get following configuration of neurons 

pos = gridtop([3, 2]) 

pos = 

     0     1     2     0     1     2 

     0     0     0     1     1     1 

 

2. In hextop topology, neurons are initially arranged in a hexagonal pattern.  

e.g. A 2-by-3 pattern of hextop neurons is generated as follows: 

pos = hextop([2, 3]) 

pos = 

         0    1.0000    0.5000    1.5000         0    1.0000 

         0         0    0.8660    0.8660    1.7321    1.7321  

Hextop is the default pattern for SOM networks generated by selforgmap 

3. The randtop function creates neurons in a random pattern in the specified dimensions.  

Pos=randtop ([2, 3]); 

Pos = 

0 0.42 0.29 0.87 0.07 0.43 

0 0.01 0.26 0.48 1.32 1.33 

Distance functions 



Distances between neurons are calculated from their positions with a distance function. There are four 

distance functions, dist, boxdist, linkdist, and mandist 

The link distance from one neuron is just the number of links, or steps that must be taken to get to the 

neuron under consideration.  

The dist is Euclidean distance from neuron to a point. 

The mandist calculates the Manhattan distance between points. 

Creating a Self-Organizing Map Neural Network (selforgmap) - 

SOM is created using selforgmap function whose syntax is as given below. 

Selforgmap (dimensions, coversteps, initNeighbour, topologyFunction, distanceFunction) 

Where the parameters can take following value- 

1. dimensions is a row vector of dimension sizes of the initial neurons. Default value= [8 8]. 

2.  coversteps is number of training steps to cover the whole input dataset initially(Default=100) 

3.  initNeighbour is the size of initial neighbourhood.(default =3) 

4. topologyFunction is the initial topology of neurons (default =’hextop’) 

5. distanceFunction is neuron distance function (default=’linkdist’) 

Suppose you want to cluster n points located in 2D space into k clusters based on Euclidean distance- 

Let x be a matrix with dimension 2*n which contains the coordinate of points. 

net = selforgmap([2 k/2], 100, 3, , ‘gridtop’, dist‘); 

You can set the no of iterations the neural network will train using 

net.trainParam.epochs=1000; 

Network is trained using train (network, dataset) as  

net = train(net, x); 

To get the cluster id of the points by passing them as input to the learnt neural network- 

y=net(x); 

y would be a 4*n matrix. The ith column of y would be the output for the ith point and all the entries in the 

column would be zero except one which is the cluster to which that points belong or more precisely the 

node which is the cluster head of the ith point. 

To get cluster-id in range (1, k)- 

IDX=vec2ind(y); 

Where IDX is a n length vector. 

Now we have to get the geometrical centroid of each cluster which can be obtained by iterating through all 

the points that belong to that cluster and finding mean of their position vectors. 

https://in.mathworks.com/help/nnet/ref/dist.html
https://in.mathworks.com/help/nnet/ref/boxdist.html
https://in.mathworks.com/help/nnet/ref/linkdist.html
https://in.mathworks.com/help/nnet/ref/mandist.html


On running the above code, a GUI nntraintool appears in which there are several visualizations of the 

network that is learnt like SOM topology, SOM neighbor connection, SOM neighbor distances, SOM input 

planes, SOM sample hits, SOM Weight positions. 

 

Interfacing WSN Simulation in NetSim with SOM algorithm running in MATLAB: 

SOM based clustering is implemented in NetSim by Interfacing with MATLAB for the purpose of running 

the SOM algorithm. The sensor coordinates are fed as input to MATLAB and Self Organizing map neural 

network algorithm that is implemented in MATLAB is used to dynamically perform clustering of the sensors 

into n number of clusters. 

In addition to clustering we also determine the cluster head of each cluster mathematically in MATLAB. The 

distance of each sensor from the centroid of the cluster to which it belongs is calculated. Then the sensor 

which has the least distance is elected as the cluster head. 

From MATLAB we get the cluster id of each sensor, cluster heads of each cluster and the size of each 

cluster. 

All the above steps are performed periodically which can be defined as per the implementation. Each time 

the cluster members and the cluster heads are determined based on the current position and they are not 

fixed. 

The codes required for the mathematical calculations done in MATLAB are written to a 

som_optimization.m file and user need to place this file inside the root directory of MATLAB.  

For Eg: “C:\Program Files\MATLAB\R2016a”. 

 

A SOM_Clustering.c file is added to the DSR project which contains the following functions: 



 
 
fn_NetSim_som_clustering_CheckDestination() 
 This function is used to determine whether the current device is the destination. 
 
fn_NetSim_som_clustering_GetNextHop() 
 This function statically defines the routes within the cluster and from cluster to sinknode. It returns 
the next hop based on the static routing that is defined. 
 
fn_NetSim_som_clustering_IdentifyCluster() 
 This function returns the cluster id of the cluster to which a sensor belongs. 
 
fn_NetSim_som_clustering_run() - This function makes a call to MATLAB interfacing function and passes 
the inputs from NetSim (i.e) the sensor coordinates, number of clusters and the sensor count. 

 

fn_netsim_som_form_clusters() - This function assigns each sensor to its respective clusters based on 
the cluster id’s obtained from MATLAB. 

 

fn_netsim_assign_cluster_heads() - This function assigns the cluster heads for each cluster based on 
the cluster head id’s obtained from MATLAB. 

 

fn_NetSim_som_Clustering_Init() - This function initializes all parameter values. 

 
Static Routing: 
 
Static Routing is defined in such a way that the sensors in the cluster send the packets to the cluster head. 
The cluster head then directly sends the packets to the destination (sinknode). 
 
If the current sensor is the source device and if it is not a cluster head then its next hop is its cluster head. 
 
If the current sensor is the source device and if it is a cluster head then its next hop is the destination (i.e) 
the sinknode. 
 
If the current sensor is not the source then the packet is sent to the destination (i.e) the sinknode.  
 



 
Steps to run SOM Clustering Code in NetSim: 

 

1. The downloaded project folder contains the folders Documentation, MATLAB_Code and 

SOM_Optimization_Workspace directory as shown below: 

 
2. Import SOM_Optimization_Workspace by going to Open Simulation->Workspace Options->More 

Options in NetSim Home window. Then select Import as shown below: 

 
3. It displays a window where users need to give the path of the workspace folder and click on OK 

as shown below: 



 
4. Browse to the SOM_Optimization_Workspace folder and click on select folder as shown below: 

 
5. After this click on OK button in the Import Workspace window. 

6. While importing the workspace, if the following warning message indicating Software Version 

Mismatch is displayed, you can ignore it and proceed. 



 
7. The Imported workspace will be set as the current workspace automatically. To see the imported 

workspace, click on Open Simulation->Workspace Options->More Options as shown below: 

 
8. Create a user variable with the name of MATLAB_PATH and provide the path of the installation 

directory of user’s respective MATLAB version.  



 
9. Make sure that the following directory is in the PATH(Environment variable) 

<Path where MATLAB is installed>\bin\win64 
 

 
 

Note: If the machine has more than one MATLAB installed, the directory for the target platform 
must be ahead of any other MATLAB directory (for instance, when compiling a 64-bit application, 
the directory in the MATLAB 64-bit installation must be the first one on the PATH). 

10. Open Command prompt as admin and execute the command “matlab -regserver”. This will register 
MATLAB as a COM automation server and is required for NetSim to start MATLAB automation 
server during runtime.  

 
 

11. Place clustering.m present in the MATLAB_Code folder inside the root directory of MATLAB. For 

Example: “C:\Program Files\MATLAB\R2016a”. 
 



 
 

12. Open the Source codes in Visual Studio by going to Open Simulation-> Workspace Options and 
Clicking on Open code button as shown below: 

 
 

13. Under the DSR project in the solution explorer you will be able to see that MATLAB_Interface.c 

and Som_clustering.c files which contain source codes related to interactions with MATLAB and 

handling clustering in NetSim respectively. 

14. Based on whether you are using NetSim 32 bit or 64 bit setup you can configure Visual studio to 
build 32 bit or 64 bit Dll files respectively as shown below: 



 
15. Right click on the DSR project in the solution explorer and select Rebuild. 

 
 

16. Upon successful build modified libDSR.dll file gets automatically updated in the directory containing 
NetSim binaries. 
 

17. Run NetSim as Administrative mode. 
 

18. Then SOM_Optimization_Workspace comes with a sample configuration that is already saved. To 
open this example, go to Open Simulation and click on the Som_clustering_Example that is present 
under the list of experiments as shown below: 
 



 
 

19. The saved network scenario consisting of 64 sensors uniformly distributed in the grid environment 
along with a sink node forming a Wireless Sensor Network. Traffic is configured from each sensor 
node to the Sink Node. 

 



20. Run the Scenario. You will observe that as the scenario starts and MATLAB plots the graph for the 
cluster that is formed currently and also Neural Network Training Window opens up which has 
several options as discussed next. 

12. There are two algorithms implemented to find the best clusters and cluster heads which uses SOM 
with distance as metric and other is modified version of the first algorithm where a function of both 
remaining power and the distance from cluster head is minimized over all the sensors in the cluster to 
get the cluster head with least distance from geometrical centroid of cluster and maximum remaining 
power. 

SOM using distance as a metric to identify the cluster head (Clustering_Method = 1) 

The clusters would be created so as to minimize the sum of distance between the sensor and the 
sensor which is cluster head. The remaining power in each sensor isn’t taken into account in this 
algorithm. 

 

 

      Fig:  plot for power consumption 

64 sensors are placed evenly on x-y plane and each sensor is given a fixed amount of initial power 
(100 in this case). The number of clusters has been fixed to 4. 

The z axis represents the power consumed while the sensors are placed on the x, y plane.  

It can be seen from the plot, there are 4 peaks in the plot corresponding to 4 sensors that will be 
selected as the cluster heads. Since the sensors are static, there are same cluster heads and cluster 
during the whole simulation period. 

Nntraintool GUI will appear like shown below. 

It has several Menu buttons like SOM Topology, SOM Neighbor connections, SOM Neighbor distances, 
SOM Input Planes, SOM Sample Hits, SOM Weight Positions. 



SOM Topology- The plot would represent a rectangular grid in this case. 

SOM Neighbor distances – It shows the distance of sensors from cluster centers as computed using 
distance function and the neighborhood of each  cluster centers are shaded in different colors. 

SOM Weight Positions- The cluster centers are shown at their weight vector (using them as position 
vector) along with all the sensors in the WSN. 

 

 

Clicking on Weight Positions you would get the following plot. 



 

Here the three points in blue shows the final weight positions of the trained neural network. 

The green points are the sensors whose position vectors were used as input to the neural network 
while training. Weight1 and Weight2 are corresponding to x coordinate and y coordinate of the position 
vectors of input. 

 

Modified SOM using power and distance as metric for electing cluster head(Clustering_Method = 2) 

Algorithm- SOM library of MATLAB is used to find the cluster id of each sensor and the sensor for which 
the objective function (composed of power and distance from cluster center) is minimum is chosen as 
cluster head. 

The power consumption obtained using this is close to that of kmeans in the uniform placement of 
sensors but it might differ in case of complex distribution of placement of sensors. 

In the initial phase the plot resembles the previous one. But after some time, since the power associated 
with cluster heads would decrease fast and so, there would be new cluster head whose distance from 
geometrical centroid of cluster is considerably low and power is also high. Hence as the time passes, 
it can be observed that the power is consumed by all the sensors at approximately the same rate. 

There are no peaks in this plot unlike the previous one because modified SOM takes into account the 
power level of each sensor and thus each sensor will be appointed as the cluster head in its respective 
cluster. 

File log.txt is created in DSR folder which contains the location of cluster heads and the sensor no 
which is cluster head from the start of simulation. 

File time.txt in bin folder contains the time from which the sensor power starts becoming zero and the 
no of sensors with zero power and subsequently which has been shown in the table at end of document. 



 

Fig: plot for power consumption of sensors. 

Case 3: Recalculating clusters iteratively after getting cluster using SOM initially. 

Algorithm: 

Initially, cluster is evaluated using SOM which uses distance as metric. The cluster to which each sensor 
belongs to is known. Now, cluster head is chosen as the sensor for which the objective function which 
constitutes remaining power and the distance from geometrical centroid of cluster to the sensor, is 
minimized. 

After this cluster is recalculated and each sensor is assigned to the cluster whose cluster head is closest 
to it. Cluster heads and then the cluster is computed iteratively.  

 

 

 

 

 

 


